(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(chromium)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(61.0.3163.100)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("chromium web browser"))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://www.chromium.org/"))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (x86_64))} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (BSD))} spids:[30])]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ (xdg-utils))} spids:[35])]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends_dev) op:Equal rhs:{(DQ )} spids:[40])]
      spids: [40]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$depends_dev") ("\n") ("\talsa-lib-dev\n") ("\tbash\n") 
                ("\tbinutils-gold\n") ("\tbison flex\n") ("\tbsd-compat-headers\n") ("\tbzip2-dev\n") ("\tcairo-dev\n") ("\tcups-dev\n") 
                ("\tdbus-glib-dev\n") ("\teudev-dev\n") ("\tffmpeg-dev\n") ("\tfindutils\n") ("\tflac-dev\n") ("\tfreetype-dev\n") 
                ("\tgnutls-dev\n") ("\tgperf\n") ("\tgtk+-dev\n") ("\tgzip\n") ("\tharfbuzz-dev\n") ("\thunspell-dev\n") ("\thwdata-usb\n") 
                ("\tjpeg-dev\n") ("\tjsoncpp-dev\n") ("\tkrb5-dev\n") ("\tlibbsd-dev\n") ("\tlibcap-dev\n") ("\tlibelf-dev\n") 
                ("\tlibexif-dev\n") ("\tlibgcrypt-dev\n") ("\tlibgnome-keyring-dev\n") ("\tlibjpeg-turbo-dev\n") ("\tlibpng-dev\n") 
                ("\tlibusb-dev\n") ("\tlibwebp-dev\n") ("\tlibxcomposite-dev\n") ("\tlibxcursor-dev\n") ("\tlibxinerama-dev\n") 
                ("\tlibxml2-dev\n") ("\tlibxrandr-dev\n") ("\tlibxscrnsaver-dev\n") ("\tlibxslt-dev\n") ("\tlibxtst-dev\n") 
                ("\tlinux-headers\n") ("\tmesa-dev\n") ("\tmesa-dev\n") ("\tminizip-dev\n") ("\tninja\n") ("\tnodejs\n") ("\tnss-dev\n") 
                ("\tpaxmark\n") ("\tpciutils-dev\n") ("\tperl\n") ("\tpython2\n") ("\tsnappy-dev\n") ("\tspeex-dev\n") ("\tsqlite-dev\n") 
                ("\txdg-utils\n") ("\tyasm\n") ("\tzlib-dev\n") ("\t")
              )
            }
          spids: [44]
        )
      ]
      spids: [44]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(DQ )} spids:[110])]
      spids: [110]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends)
          op: Equal
          rhs: {(DQ ("eudev-libs ttf-opensans"))}
          spids: [117]
        )
      ]
      spids: [117]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:options) op:Equal rhs:{(suid)} spids:[122])]
      spids: [122]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") ("-doc ") ($ VSub_Name "$pkgname") (-chromedriver))}
          spids: [125]
        )
      ]
      spids: [125]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("https://commondatastorage.googleapis.com/chromium-browser-official/") 
                ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver") (".tar.xz\n") 
                (
"\tpstables-2.8.h::http://git.savannah.gnu.org/cgit/freetype/freetype2.git/plain/src/psnames/pstables.h?h=VER-2-8\n"
                ) ("\tchromium-launcher.sh\n") ("\tchromium.conf\n") ("\tchromium.desktop\n") ("\tgoogle-api.keys\n") 
                ("\n") ("\tchromium-widevine.patch\n") ("\tdefault-pthread-stacksize.patch\n") ("\tgcc6.patch\n") 
                ("\tgn_bootstrap.patch\n") ("\tlast-commit-position.patch\n") ("\tmusl-fixes.patch\n") ("\tmusl-hacks.patch\n") 
                ("\tmusl-libc++.patch\n") ("\tmusl-sandbox.patch\n") ("\tno-execinfo.patch\n") ("\tno-getcontext.patch\n") 
                ("\tno-mallinfo.patch\n") ("\tresolver.patch\n") ("\tunset-madv_free.patch\n") ("\tswiftshader.patch\n") 
                ("\tsecure_getenv.patch\n") ("\tgcc-fixes.patch\n") ("\tfix-atk.patch\n") 
                ("\tchromium-48.0.2564.116-libusb_interrupt_event_handler.patch\n") ("\tchromium-60.0.3112.78-gn-system.patch\n") ("\tchromium-60.0.3112.78-jpeg-nomangle.patch\n") 
                ("\tchromium-60.0.3112.78-no-libpng-prefix.patch\n") ("\tchromium-60.0.3112.78-no-zlib-mangle.patch\n") ("\tchromium-61.0.3163.79-gcc5-r1.patch\n") 
                ("\tchromium-61.0.3163.79-gtk2fix.patch\n") ("\t")
              )
            }
          spids: [133]
        )
      ]
      spids: [133]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver")}
          spids: [175]
        )
      ]
      spids: [175]
    )
    (Case
      to_match: {(DQ (${ VSub_Name CARCH))}
      arms: [
        (case_arm
          pat_list: [{(x86_64)}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:target_arch) op:Equal rhs:{(x64)} spids:[199])]
              spids: [199]
            )
          ]
          spids: [196 197 201 -1]
        )
        (case_arm
          pat_list: [{(x86)}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:target_arch) op:Equal rhs:{(ia32)} spids:[207])]
              spids: [207]
            )
          ]
          spids: [204 205 209 -1]
        )
        (case_arm
          pat_list: [{(arm)}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:target_arch) op:Equal rhs:{(arm)} spids:[215])]
              spids: [215]
            )
          ]
          spids: [212 213 217 -1]
        )
      ]
      spids: [185 193 219]
    )
    (If
      arms: [
        (if_arm
          cond: [
            (Sentence
              child: (C {(Lit_Other "[")} {(-n)} {(DQ ($ VSub_Name "$DEBUG"))} {(Lit_Other "]")})
              terminator: <Op_Semi ";">
            )
          ]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:_buildtype) op:Equal rhs:{(Debug)} spids:[238])]
              spids: [238]
            )
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:_is_debug) op:Equal rhs:{(true)} spids:[242])]
              spids: [242]
            )
          ]
          spids: [-1 235]
        )
      ]
      else_action: [
        (Assignment
          keyword: Assign_None
          pairs: [(assign_pair lhs:(LhsName name:_buildtype) op:Equal rhs:{(Release)} spids:[248])]
          spids: [248]
        )
        (Assignment
          keyword: Assign_None
          pairs: [(assign_pair lhs:(LhsName name:_is_debug) op:Equal rhs:{(false)} spids:[252])]
          spids: [252]
        )
      ]
      spids: [245 255]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[275])]
              spids: [273]
            )
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name "$i")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name "$i")})
                              terminator: <Op_Semi ";">
                            )
                            (C {(patch)} {(-p0)} {(-i)} 
                              {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                            )
                          ]
                          spids: [304 306 324 -1]
                        )
                      ]
                      spids: [297 301 327]
                    )
                  ]
                  spids: [294 330]
                )
              spids: [290 292]
            )
            (C {(touch)} {(chrome/test/data/webui/i18n_process_css_test.html)})
            (C {(sed)} {(SQ <"s|//third_party/usb_ids/usb.ids|/usr/share/hwdata/usb.ids|g">)} {(-i)} 
              {(device/usb/BUILD.gn)}
            )
            (C {(mkdir)} {(-p)} {(third_party/node/linux/node-linux-x64/bin)})
            (C {(ln)} {(-s)} {(/usr/bin/node)} {(third_party/node/linux/node-linux-x64/bin/)})
          ]
          spids: [262]
        )
      spids: [258 261]
    )
    (FuncDef
      name: _gn_flags
      body: (BraceGroup children:[(C {(echo)} {($ VSub_Star "$*")})] spids:[383])
      spids: [379 382]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:use_system)
                  op: Equal
                  rhs: 
                    {
                      (DQ ("\n") ("\t\tflac\n") ("\t\tfreetype\n") ("\t\tharfbuzz-ng\n") ("\t\tlibdrm\n") 
                        ("\t\tlibjpeg\n") ("\t\tlibpng\n") ("\t\tlibwebp\n") ("\t\tlibxslt\n") ("\t\tsnappy\n") ("\t\tyasm\n") ("\t\tzlib\n") 
                        ("\t\t")
                      )
                    }
                  spids: [413]
                )
              ]
              spids: [411]
            )
            (ForEach
              iter_name: _lib
              iter_words: [{(${ VSub_Name use_system)} {(libjpeg_turbo)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(msg)} 
                      {(DQ ("Removing buildscripts for system provided ") ($ VSub_Name "$_lib"))}
                    )
                    (C {(find)} {(-type)} {(f)} {(-path)} 
                      {(DQ ("*third_party/") ($ VSub_Name "$_lib") ("/*"))} {(EscapedLiteralPart token:<Lit_EscapedChar "\\!">)} {(-path)} 
                      {(DQ ("*third_party/") ($ VSub_Name "$_lib") ("/chromium/*"))} {(EscapedLiteralPart token:<Lit_EscapedChar "\\!">)} {(-path)} 
                      {(DQ ("*third_party/") ($ VSub_Name "$_lib") ("/google/*"))} {(EscapedLiteralPart token:<Lit_EscapedChar "\\!">)} {(-regex)} 
                      {(SQ <".*\\.\\(gn\\|gni\\|isolate\\|py\\)">)} {(-delete)}
                    )
                  ]
                  spids: [444 508]
                )
              spids: [436 442]
            )
            (C {(mkdir)} {(-p)} {(DQ (third_party/freetype/src/src/psnames/))})
            (C {(cp)} {(DQ ($ VSub_Name "$srcdir")) (/pstables-2.8.h)} 
              {(third_party/freetype/src/src/psnames/pstables.h)}
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:CFLAGS)
                  op: Equal
                  rhs: {(DQ ($ VSub_Name "$CFLAGS") (" -fno-delete-null-pointer-checks"))}
                  spids: [564]
                )
              ]
              spids: [564]
            )
            (C {(msg)} {(DQ ("Replacing gyp files"))})
            (C {(python)} {(build/linux/unbundle/replace_gn_files.py)} {(--system-libraries)} 
              {(${ VSub_Name use_system)}
            )
            (C {(third_party/libaddressinput/chromium/tools/update-strings.py)})
            (C {(eval)} 
              {
                (DQ 
                  (CommandSubPart
                    command_list: 
                      (CommandList
                        children: [
                          (SimpleCommand
                            words: [{(base64)} {(-d)}]
                            redirects: [
                              (Redir
                                op_id: Redir_Less
                                fd: -1
                                arg_word: {($ VSub_Name "$srcdir") (/google-api.keys)}
                                spids: [624]
                              )
                            ]
                          )
                        ]
                      )
                    left_token: <Left_CommandSub "$(">
                    spids: [619 628]
                  )
                )
              }
            )
            (C {(msg)} {(DQ ("Bootstrapping GN"))})
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_c)
                  op: Equal
                  rhs: 
                    {
                      (CommandSubPart
                        command_list: 
                          (CommandList
                            children: [
                              (C {(_gn_flags)} {(Lit_VarLike "is_clang=") (false)} 
                                {(Lit_VarLike "use_sysroot=") (false)} {(Lit_VarLike "treat_warnings_as_errors=") (false)} {(Lit_VarLike "fatal_linker_warnings=") (false)} 
                                {(Lit_VarLike "binutils_path=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) (/usr/bin) (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } {(Lit_VarLike "use_gconf=") (false)} {(Lit_VarLike "use_gold=") (true)} 
                                {(Lit_VarLike "use_allocator=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) (none) (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } {(Lit_VarLike "use_allocator_shim=") (false)}
                              )
                            ]
                          )
                        left_token: <Left_CommandSub "$(">
                        spids: [643 695]
                      )
                    }
                  spids: [642]
                )
              ]
              spids: [640]
            )
            (C {(python)} {(tools/gn/bootstrap/bootstrap.py)} {(--gn-gen-args)} {(DQ ($ VSub_Name "$_c"))})
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_c)
                  op: Equal
                  rhs: 
                    {
                      (CommandSubPart
                        command_list: 
                          (CommandList
                            children: [
                              (C {(_gn_flags)} {(Lit_VarLike "enable_hotwording=") (false)} 
                                {(Lit_VarLike "enable_nacl=") (false)} {(Lit_VarLike "enable_nacl_nonsfi=") (false)} {(Lit_VarLike "enable_precompiled_headers=") (false)} 
                                {(Lit_VarLike "ffmpeg_branding=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) (Chrome) (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } {(Lit_VarLike "fieldtrial_testing_like_official_build=") (true)} 
                                {(Lit_VarLike "google_api_key=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) ($ VSub_Name "$_google_api_key") (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } 
                                {(Lit_VarLike "google_default_client_id=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) ($ VSub_Name "$_google_default_client_id") (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } 
                                {(Lit_VarLike "google_default_client_secret=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) ($ VSub_Name "$_google_default_client_secret") (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } {(Lit_VarLike "is_clang=") (false)} {(Lit_VarLike "is_debug=") ($ VSub_Name "$_is_debug")} 
                                {(Lit_VarLike "linux_use_bundled_binutils=") (false)} {(Lit_VarLike "proprietary_codecs=") (true)} {(Lit_VarLike "symbol_level=") (0)} 
                                {(Lit_VarLike "treat_warnings_as_errors=") (false)} 
                                {(Lit_VarLike "use_allocator=") 
                                  (EscapedLiteralPart
                                    token: <Lit_EscapedChar "\\\"">
                                  ) (none) (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">)
                                } {(Lit_VarLike "use_allocator_shim=") (false)} {(Lit_VarLike "use_gconf=") (false)} 
                                {(Lit_VarLike "use_gnome_keyring=") (false)} {(Lit_VarLike "use_pulseaudio=") (false)} {(Lit_VarLike "use_sysroot=") (false)}
                              )
                            ]
                          )
                        left_token: <Left_CommandSub "$(">
                        spids: [712 832]
                      )
                    }
                  spids: [711]
                )
              ]
              spids: [711]
            )
            (C {(out/Release/gn)} {(gen)} {(out/) ($ VSub_Name "$_buildtype")} 
              {(--args) (Lit_Other "=") (DQ ($ VSub_Name "$_c"))}
            )
            (C {(msg)} {(DQ ("Ninja turtles GO!"))})
            (C {(ninja)} {(-C)} {(out/) ($ VSub_Name "$_buildtype")} {(mksnapshot)})
            (C {(paxmark)} {(-m)} {(out/) ($ VSub_Name "$_buildtype") (/mksnapshot)})
            (C {(ninja)} {(-C)} {(out/) ($ VSub_Name "$_buildtype")} {(chrome)} {(chrome_sandbox)} 
              {(chromedriver)}
            )
          ]
          spids: [397]
        )
      spids: [393 396]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair lhs:(LhsName name:bin) op:Equal spids:[918])
                (assign_pair lhs:(LhsName name:pak) op:Equal spids:[920])
              ]
              spids: [916]
            )
            (C {(paxmark)} {(-m)} {(out/) ($ VSub_Name "$_buildtype") (/mksnapshot)})
            (ForEach
              iter_name: bin
              iter_words: [{(chrome)} {(natives_blob.bin)} {(snapshot_blob.bin)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(install)} {(-Dm755)} 
                      {(out/) ($ VSub_Name "$_buildtype") (/) ($ VSub_Name "$bin")} {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/) ($ VSub_Name "$bin")}
                    )
                  ]
                  spids: [950 973]
                )
              spids: [942 948]
            )
            (C {(paxmark)} {(-m)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/chrome)}
            )
            (C {(install)} {(-Dm4755)} 
              {(DQ ($ VSub_Name "$builddir")) (/out/) ($ VSub_Name "$_buildtype") (/chrome_sandbox)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/chrome-sandbox)}
            )
            (C {(install)} {(-m644)} 
              {(DQ ($ VSub_Name "$builddir")) (/out/) ($ VSub_Name "$_buildtype") (/icudtl.dat)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/icudtl.dat)}
            )
            (ForEach
              iter_name: pak
              iter_words: [{(out/) ($ VSub_Name "$_buildtype") (/) (Lit_Other "*") (.pak)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(install)} {(-Dm644)} {($ VSub_Name "$pak")} 
                      {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/) 
                        (BracedVarSub
                          token: <VSub_Name pak>
                          suffix_op: (StringUnary op_id:VOp1_DPound arg_word:{("*") (Lit_Slash /)})
                          spids: [1063 1068]
                        )
                      }
                    )
                  ]
                  spids: [1046 1071]
                )
              spids: [1038 1044]
            )
            (C {(install)} {(-Dm755)} {(DQ ($ VSub_Name "$srcdir")) (/chromium-launcher.sh)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") 
                (/chromium-launcher.sh)
              }
            )
            (C {(cp)} {(-r)} {(out/) ($ VSub_Name "$_buildtype") (/locales)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/)}
            )
            (C {(install)} {(-Dm644)} {(out/) ($ VSub_Name "$_buildtype") (/chrome.1)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/man/man1/chrome.1)}
            )
            (C {(install)} {(-Dm644)} {(out/) ($ VSub_Name "$_buildtype") (/chrome.1)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/man/man1/chromium.1)}
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/bin)})
            (C {(cd)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/bin)})
            (C {(ln)} {(-sf)} {(/usr/lib/) ($ VSub_Name "$pkgname") (/chromium-launcher.sh)} 
              {(chromium-browser)}
            )
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C {(install)} {(-Dm644)} {(DQ ($ VSub_Name "$srcdir")) (/chromium.conf)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/chromium/chromium.conf)}
            )
            (C {(install)} {(-Dm644)} {(DQ ($ VSub_Name "$srcdir")) (/chromium.desktop)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/applications/chromium.desktop)}
            )
            (ForEach
              iter_name: size
              iter_words: [{(22)} {(24)} {(48)} {(64)} {(128)} {(256)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(install)} {(-Dm644)} 
                      {(DQ (chrome/app/theme/chromium/product_logo_) ($ VSub_Name "$size") (.png))} 
                      {
                        (DQ ($ VSub_Name "$pkgdir") (/usr/share/icons/hicolor/) (${ VSub_Name size) (x) 
                          (${ VSub_Name size) (/apps/chromium.png)
                        )
                      }
                    )
                  ]
                  spids: [1246 1275]
                )
              spids: [1232 1244]
            )
            (ForEach
              iter_name: size
              iter_words: [{(16)} {(32)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(install)} {(-Dm644)} 
                      {
                        (DQ (chrome/app/theme/default_100_percent/chromium/product_logo_) 
                          ($ VSub_Name "$size") (.png)
                        )
                      } 
                      {
                        (DQ ($ VSub_Name "$pkgdir") (/usr/share/icons/hicolor/) (${ VSub_Name size) (x) 
                          (${ VSub_Name size) (/apps/chromium.png)
                        )
                      }
                    )
                  ]
                  spids: [1290 1319]
                )
              spids: [1284 1288]
            )
            (C {(install)} {(-Dm755)} 
              {(DQ ($ VSub_Name "$builddir")) (/out/) ($ VSub_Name "$_buildtype") (/chromedriver)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/chromedriver)}
            )
            (C {(ln)} {(-sf)} {(/usr/lib/) ($ VSub_Name "$pkgname") (/chromedriver)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/bin/)}
            )
          ]
          spids: [906]
        )
      spids: [902 905]
    )
    (FuncDef
      name: chromedriver
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ("WebDriver driver for the Chromium Browser"))}
                  spids: [1367]
                )
              ]
              spids: [1367]
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$subpkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname")} 
              {(DQ ($ VSub_Name "$subpkgdir")) (/usr/bin)}
            )
            (C {(mv)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/chromedriver)} {(DQ ($ VSub_Name "$subpkgdir")) (/usr/lib/) ($ VSub_Name "$pkgname") (/)}
            )
            (C {(mv)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/bin/chromedriver)} 
              {(DQ ($ VSub_Name "$subpkgdir")) (/usr/bin)}
            )
          ]
          spids: [1364]
        )
      spids: [1360 1363]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"4dfd3a493ceb7c605eeab6f387541273d529e8b935a6104927e34836469aedcfcbb4a1154591585621d5c2e842e68701d32328acba842f840a20498822165f78  chromium-61.0.3163.100.tar.xz\n"
                ) 
                (
"a3bb959c65944ae2fb765725cedcffd743a58bc0c2cd1f1999d15fe79801d00f3474b08b4ed7b48859ed921eb57093d0ad09d90f201d729ed9b8a419a591ed29  pstables-2.8.h\n"
                ) 
                (
"b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60  chromium-launcher.sh\n"
                ) 
                (
"f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f  chromium.conf\n"
                ) 
                (
"e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c  chromium.desktop\n"
                ) 
                (
"2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac  google-api.keys\n"
                ) 
                (
"55921cc33d623e0751e94d4fef2ddd69afb57381da6115995b1f318e2398978b9173e80f6ffbc6e6c0c0c55a04e934e0e34a46c32e03947cc31f0f5a226e7725  chromium-widevine.patch\n"
                ) 
                (
"05fb6d9434565a7a73f5c18d470ae600bf4afbe15d0e4a7c2770bf2596a0bd2788cdfeb37e0b566fc3d26ff2d0791b70488b2c184e3286cff5a1fa25e17582cd  default-pthread-stacksize.patch\n"
                ) 
                (
"88928afcc33843e17daa082435a4b88c2106b0252a202ad19f684021c027859366a0c12970700c0d1b010211eef95d295362dc6afdea1b00199dd8d2efbdcfe7  gcc6.patch\n"
                ) 
                (
"902aeffaf0a755dd856a7d96c390adafd53ff23aed0a3693acc86a680d8c001f0f565f50caafd8bac4bba6f5e04011ebd9c27cda3264fd2ffc27df2803b738b1  gn_bootstrap.patch\n"
                ) 
                (
"8fbfd67a0b6bbdf08364e810bd85b4a80dda9af73fefe3aba8010d9b33022d458a785c628515bbda9c743b8a0293d57cfe18fcc5aa2313c845c6fb948c2335f9  last-commit-position.patch\n"
                ) 
                (
"c78e868ec5b902e5fd5febca8aaf9649bd598c747d8e260683552d29bb322e2e4cb1e71d92750e3209096e24416297396cca47a6a855b657cb7685b39d06b0f0  musl-fixes.patch\n"
                ) 
                (
"507a8db2317f1f6ec18dec6cb5894b716e9b2542b58887bab9319bc6d4c66fe4a4d09b200ca8e3f11b32e380b282442a27e7a1b358d3c25eef0fa7655e9dc134  musl-hacks.patch\n"
                ) 
                (
"c38e3e30512f6f5d494bcd905b314dea52e09214f8fc779b66193f5eb3af8f1afb5cdf2d096aa4590e6a1dd28c289d26812d7268abf4459209fb8bdc8806a0be  musl-libc++.patch\n"
                ) 
                (
"9b75d6ac720d1b8ddc597f0f472bc400ff866a733f12b3a4cd3e7e18e724549c5f8e056c7e0d0462ef083bff5e677f8cef6b89b22f4740a40ad6398978269373  musl-sandbox.patch\n"
                ) 
                (
"fe2cee01d07e5dc638dad0c5453397eb03e30867c1e54591d7f612034366c96ccaa35216d2bcedbe796863eeb5b90dcf71c75e5391c266df4cb27b44e59bb040  no-execinfo.patch\n"
                ) 
                (
"a57858e45cfbb7e97f77b3b308502e377543d61d3d0085798ed73bc53da456828f5e010308d0de05fee4fe52071362d074f5af205f98f41d67222d997857d626  no-getcontext.patch\n"
                ) 
                (
"7a3a4ba4479a22a13126a78ad3d9991188ef030389026c4293d45b4440711751d68e43d28687653d5670d7f00ed5f1b820a8df50a3a08ce06e454f0cad9dbd3c  no-mallinfo.patch\n"
                ) 
                (
"ac0c9d7780ac897ea8ad5d909616d3aa29eed720353c7a660c850ee1404c80f51f5db274b3c5d3c730561a7c3cd138624e1901ece329926b5dc5ca15195d9abf  resolver.patch\n"
                ) 
                (
"27dd7916be3324294a0a913c43c856e9c00be767a2aec4f3da2455fb84e74ebb0017d1aa586b40dd9d989ada6b60fc531522f503d57e04324726a2171bf3a85e  unset-madv_free.patch\n"
                ) 
                (
"6b0812725a0fc562527f3556dc4979fec72d1ba92f26a5e78ff2016c39bb2c155a0ff95fc22101f9c097d14b84182d6615276f4247f60ae7833ab45da8366e6d  swiftshader.patch\n"
                ) 
                (
"67eea8e13c85aca7db5c85f5b0d33e5798e8063ab7f5b2f0a5c7f6fee8266e58bee4e72f4542472ef6634634ca0f4359a2d1113fa310a991373404320c784730  secure_getenv.patch\n"
                ) 
                (
"0d6935117e3531a33aab5d09093e854c7e82e799340222cd75e3a1d7e054fbe02524f59c56d01a36649da5c89042a6ce7af2313917d3d5a3947ee7c890b99ba6  gcc-fixes.patch\n"
                ) 
                (
"aa44cbc1857f407d897fba8c64faa6401aa9c30f4de0a6c79e0fb63086b0ee518e411335a53c0bd75c3023f3f064aff57270a47ffe4f8f31c251aa318570e0c2  fix-atk.patch\n"
                ) 
                (
"2e9496aa9ccd6fed2d0df4b659d55e87abb67b1be4e3cc7cb0483ccb458b9071bed9939132a2345bf15192b4dcfe5da9474d7f653ae2f4b4d46d2f3c032b3a3f  chromium-48.0.2564.116-libusb_interrupt_event_handler.patch\n"
                ) 
                (
"197ca3fd315e15c3e0b796615afbd01f65e2040027a2cde6304dea500cfaf18372ce2be88f4030bcd26651b913dd4af741a4df8803cdf9ff062a8eef9ab6c5db  chromium-60.0.3112.78-gn-system.patch\n"
                ) 
                (
"e9fcc976d2ac1b2e73d310790e76dae15111e78cd8e3efa5febd702fd9492d7d68b1b57d95bca88d5e16c0627594a00ebdeaf570df52be6e9b23a4212906c141  chromium-60.0.3112.78-jpeg-nomangle.patch\n"
                ) 
                (
"9b08e895826fdd14fd6334662b8d07807beabab7368f3fcff3fcebe76baba4c7714c55042b379da6dab1ea0b1c4e5d657bf972b644089f00b418b7c2f5b6ef1b  chromium-60.0.3112.78-no-libpng-prefix.patch\n"
                ) 
                (
"87a0c6ff4906f0c4b6f6b471ec9bf0b2e2d28431122e99a68f957474cf27ec6b073ebca14660c8858817219521d74a184b8444cf2885db21d28fa4599fcaa66f  chromium-60.0.3112.78-no-zlib-mangle.patch\n"
                ) 
                (
"b39701c208d2786cc4b68ea033807a8663358173442ce0884dbfdebaa4b784d3eae8d7c1fe96c71ce8919fea35c50e1951c6a12193c23ae3e520604b3374ca38  chromium-61.0.3163.79-gcc5-r1.patch\n"
                ) 
                (
"3820f10d6c857d2727bcb862745d4f00b217c585e7a19db56c390c3331939fdf22bee758c3ccfb4b360d75a1c05b65e3406fd27a23d69492f86d907830223063  chromium-61.0.3163.79-gtk2fix.patch"
                )
              )
            }
          spids: [1423]
        )
      ]
      spids: [1423]
    )
  ]
)