(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(docker-registry)} spids:[4])]
      spids: [4]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(2.6.1)} spids:[7])]
      spids: [7]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(3)} spids:[10])]
      spids: [10]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("An implementation of the Docker Registry HTTP API V2 for use with docker 1.6+"))}
          spids: [13]
        )
      ]
      spids: [13]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("https://github.com/docker/distribution"))}
          spids: [18]
        )
      ]
      spids: [18]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:arch)
          op: Equal
          rhs: {(DQ ("x86 x86_64 ppc64le"))}
          spids: [23]
        )
      ]
      spids: [23]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (ASL-2.0))} spids:[28])]
      spids: [28]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:makedepends) op:Equal rhs:{(DQ ("git go"))} spids:[33])]
      spids: [33]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (.pre-install))}
          spids: [38]
        )
      ]
      spids: [38]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgusers)
          op: Equal
          rhs: {(DQ (docker-registry))}
          spids: [44]
        )
      ]
      spids: [44]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkggroups)
          op: Equal
          rhs: {(DQ (docker-registry))}
          spids: [49]
        )
      ]
      spids: [49]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (-dbg))}
          spids: [54]
        )
      ]
      spids: [54]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver") (".tar.gz::") ($ VSub_Name "$url") 
                (/archive/v) ($ VSub_Name "$pkgver") (".tar.gz\n") ("\tdocker-registry.initd\n") ("\tconfig-example.patch")
              )
            }
          spids: [60]
        )
      ]
      spids: [60]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir") (/distribution-) ($ VSub_Name "$pkgver"))}
          spids: [74]
        )
      ]
      spids: [74]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (AndOr
              children: [
                (C {(default_prepare)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C {(sed)} {(-i)} {(SQ <"/^VERSION\\s*=/d">)} {(Makefile)})
            (C {(sed)} {(-Ei)} 
              {
                (DQ ("s/^(var Version") (EscapedLiteralPart token:<Lit_EscapedChar "\\s">) ("*=") 
                  (EscapedLiteralPart token:<Lit_EscapedChar "\\s">) ("*).*/") (EscapedLiteralPart token:<Lit_EscapedChar "\\1">) 
                  (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">) ($ VSub_Name "$pkgver") (EscapedLiteralPart token:<Lit_EscapedChar "\\\"">) (/)
                )
              } {(version/version.go)}
            )
          ]
          spids: [86]
        )
      spids: [82 85]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C {(mkdir)} {(-p)} {(Godeps/_workspace/src/github.com/docker)})
            (AndOr
              children: [
                (C {(ln)} {(-s)} {(DQ ($ VSub_Name "$builddir"))} 
                  {(Godeps/_workspace/src/github.com/docker/distribution)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(make)} {(clean)} {(binaries)} 
                  {(Lit_VarLike "DISTRIBUTION_DIR=") (DQ ($ VSub_Name "$builddir"))} {(Lit_VarLike "GOPATH=") (DQ ($ VSub_Name "$builddir") (/Godeps/_workspace))} 
                  {(Lit_VarLike "VERSION=") (DQ ($ VSub_Name "$pkgver"))}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [143]
        )
      spids: [139 142]
    )
    (FuncDef
      name: check
      body: 
        (BraceGroup
          children: [(C {(cd)} {(DQ ($ VSub_Name "$builddir"))}) (C {(./bin/registry)} {(--version)})]
          spids: [226]
        )
      spids: [222 225]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(755)} {(bin/registry)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/usr/bin/) ($ VSub_Name "$pkgname")}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(644)} {(cmd/registry/config-example.yml)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/etc/) ($ VSub_Name "$pkgname") (/config.yml)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(644)} {(LICENSE)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/licenses/) ($ VSub_Name "$pkgname")}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(755)} 
                  {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (.initd)} {(DQ ($ VSub_Name "$pkgdir")) (/etc/init.d/) ($ VSub_Name "$pkgname")}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(install)} {(-d)} {(-m)} {(750)} {(-o)} {($ VSub_Name "$pkgusers")} {(-g)} 
              {($ VSub_Name "$pkggroups")} {(DQ ($ VSub_Name "$pkgdir")) (/var/lib/) ($ VSub_Name "$pkgname")}
            )
          ]
          spids: [248]
        )
      spids: [244 247]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"a2175cb5ab049599e1bdae7026dc84e14b79883eca3ceaafda54497a1743103f125f65fa3922c003363dd86aa1422f539aff8b17746b9768968fef757e931c36  docker-registry-2.6.1.tar.gz\n"
                ) 
                (
"96100a4de311afa19d293a3b8a63105e1fcdf49258aa8b1752befd389e6b4a2b1f70711341ea011b450d4468bd37dbd07a393ffab3b9aa1b2213cf0fdd915904  docker-registry.initd\n"
                ) 
                (
"5a38f4d3f0ee5cd00c0a5ced744eb5b29b839da5921adea26c5de3eb88b6b2626a7ba29b1ab931e5f8fbfafbed8c94cb972a58737ec0c0a69cf515c32139e387  config-example.patch"
                )
              )
            }
          spids: [396]
        )
      ]
      spids: [396]
    )
  ]
)