(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgname)
          op: Equal
          rhs: {(virtualbox-guest-additions)}
          spids: [7]
        )
      ]
      spids: [7]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(5.1.26)} spids:[10])]
      spids: [10]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[14])]
      spids: [14]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("VirtualBox Addtions userland components"))}
          spids: [17]
        )
      ]
      spids: [17]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(SQ <"x86 x86_64">)} spids:[22])]
      spids: [22]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(SQ <"http://virtualbox.org">)}
          spids: [27]
        )
      ]
      spids: [27]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ ("GPL custom"))} spids:[32])]
      spids: [32]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (.pre-install))}
          spids: [37]
        )
      ]
      spids: [37]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ("sed kbuild lvm2-dev yasm nasm zlib-dev libressl-dev curl-dev"))}
          spids: [43]
        )
      ]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ )} spids:[48])]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("http://download.virtualbox.org/virtualbox/") ($ VSub_Name "$pkgver") (/VirtualBox-) 
                ($ VSub_Name "$pkgver") (".tar.bz2\n") ("\tfutimens.patch\n") ("\tmusl-fix-headers.patch\n") ("\tmusl-no-glibc.patch\n") 
                ("\tmusl-fix-stat-nsec.patch\n") ("\tmusl-sched_yield.patch\n") ("\tuclibc-gnu_linux.patch\n") ("\tvboxguestlib-makefile-nox11.patch\n") 
                ("\tvirtualbox-guest-additions-localconfig\n") ("\t") ($ VSub_Name "$pkgname") (".initd\n") ("\t")
              )
            }
          spids: [52]
        )
      ]
      spids: [52]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir")) (/VirtualBox-) ($ VSub_Name "$pkgver")}
          spids: [74]
        )
      ]
      spids: [74]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (C {(rm)} {(-rf)} {($ VSub_Name "$_builddir") (/kBuild/bin)} 
              {($ VSub_Name "$_builddir") (/tools)}
            )
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[109])]
              spids: [107]
            )
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name "$i")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name "$i")})
                              terminator: <Op_Semi ";">
                            )
                            (AndOr
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [131 133 157 -1]
                        )
                      ]
                      spids: [124 128 160]
                    )
                  ]
                  spids: [121 163]
                )
              spids: [117 119]
            )
            (C {(cp)} {($ VSub_Name "$srcdir") (/) ($ VSub_Name "$pkgname") (-localconfig)} 
              {(LocalConfig.kmk)}
            )
          ]
          spids: [86]
        )
      spids: [82 85]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (C {(./configure)} {(--nofatal)} {(--disable-dbus)} {(--disable-xpcom)} {(--disable-sdl-ttf)} 
              {(--disable-pulse)} {(--disable-alsa)} {(--disable-kmods)} {(--build-headless)}
            )
            (C {(source)} {(./env.sh)})
            (C {(kmk)} {(Lit_VarLike "KBUILD_VERBOSE=") (2)})
          ]
          spids: [182]
        )
      spids: [178 181]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (C {(install)} {(-v)} {(-Dm755)} 
              {(DQ ($ VSub_Name "$_builddir")) (/out/linux.) (Lit_Other "*") 
                (/release/bin/additions/VBoxService)
              } {(DQ ($ VSub_Name "$pkgdir") (/usr/sbin/VBoxService))}
            )
            (C {(install)} {(-v)} {(-Dm755)} 
              {(DQ ($ VSub_Name "$_builddir")) (/out/linux.) (Lit_Other "*") 
                (/release/bin/additions/VBoxControl)
              } {(DQ ($ VSub_Name "$pkgdir") (/usr/bin/VBoxControl))}
            )
            (C {(install)} {(-v)} {(-Dm755)} 
              {(DQ ($ VSub_Name "$_builddir")) (/out/linux.) (Lit_Other "*") 
                (/release/bin/additions/mount.vboxsf)
              } {(DQ ($ VSub_Name "$pkgdir") (/usr/sbin/mount.vboxsf))}
            )
            (C {(install)} {(-v)} {(-Dm755)} 
              {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (.initd)} {(DQ ($ VSub_Name "$pkgdir")) (/etc/init.d/) ($ VSub_Name "$pkgname")}
            )
          ]
          spids: [246]
        )
      spids: [242 245]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"680e9646a51a0a5923b3ded10007ee1c1e2a41c6d8a961d2b2540db6578bed2847154f4cac87e3cfe1118a62595b47c7df99da854f6c340e173b9eb8cacf2add  VirtualBox-5.1.26.tar.bz2\n"
                ) 
                (
"1da850bc30399ecde501eba5403ef1add1ae108d38394b01cd7f5cdf0462b855793d564d3adc1f770983b36529d77f3f7b0269fb65152468084a0a44c38e1638  futimens.patch\n"
                ) 
                (
"0169a620d62aa3de8124e0084f4b747b602fbdcab7892fe075606459e0200d412321c86da4c5d98309f4d7479ae1b5267ed28bea6c6e64fd8be88cab74f8e94c  musl-fix-headers.patch\n"
                ) 
                (
"b1c47cb910ac751df7bd4bc10c5501e91d88a9b3e4fe181b02755d433df8e89a160a38422912266f0cc51ba0c09854dad513ba6f2634fc76c59cee7989b259eb  musl-no-glibc.patch\n"
                ) 
                (
"2c329085915f0ffa43828a14d8b29d0d876e48e18a0190ad146cd0731af7eca11cdf41d2e533c9cc73aa75506b9b91e3a08f2272cd8884e0d929722730b99862  musl-fix-stat-nsec.patch\n"
                ) 
                (
"56c5c3a0becd8f1886010f5f231aa1d2e129bf188f8220e111fb9d51c191a429940edec700f5286b46dadbb45b62e67ee4e09fec6bcea61a344fb65afcbd6756  musl-sched_yield.patch\n"
                ) 
                (
"d2bba9de80c40bc258b025a8e3395a4b0b7781d70d5528993f0fff57e9fc015306b483d4da14e22aed3f188ffda8685aa51e13943f48c17ae18a2a66d15d7bbb  uclibc-gnu_linux.patch\n"
                ) 
                (
"0ced8df03a354e211fd0631d3971246d75de3a60c2347b5fe33236405d55911422d53eb7c679ae6fc18dc8f57c245d5701fa02ae740d1f0bd1e1cbb0b715bf2f  vboxguestlib-makefile-nox11.patch\n"
                ) 
                (
"43555e442f85424c957d51a737394c6f2ec0782e5b8701e3bc6a08d17ae2e8e6e9e85734d69853f7151f91f951a9a921c4f0c5d5f6b72e8379526c49f070d49b  virtualbox-guest-additions-localconfig\n"
                ) 
                (
"ad6ff256def558f5c6b772c62a3e7a6ccd067ae208491e02ce6738a501d02bcac214056825b804c19fd21b33f3752c62bd8572eb8764f6c5eb10534fa668bd38  virtualbox-guest-additions.initd"
                )
              )
            }
          spids: [335]
        )
      ]
      spids: [335]
    )
  ]
)