(command.CommandList
  children: [
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'pkgname='> name:pkgname)
          op: assign_op.Equal
          rhs: {<diod>}
          spids: [6]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'pkgver='> name:pkgver)
          op: assign_op.Equal
          rhs: {<1.0.24>}
          spids: [9]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'pkgrel='> name:pkgrel)
          op: assign_op.Equal
          rhs: {<2>}
          spids: [12]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'pkgdesc='> name:pkgdesc)
          op: assign_op.Equal
          rhs: {(DQ <'Distributed I/O Daemon - a 9P file server'>)}
          spids: [15]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'url='> name:url)
          op: assign_op.Equal
          rhs: {(DQ <'http://github.com/chaos/diod'>)}
          spids: [20]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'arch='> name:arch)
          op: assign_op.Equal
          rhs: {(DQ <all>)}
          spids: [25]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'license='> name:license)
          op: assign_op.Equal
          rhs: {(DQ <GPLv2>)}
          spids: [30]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'depends='> name:depends)
          op: assign_op.Equal
          rhs: {(DQ )}
          spids: [35]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'depends_dev='> name:depends_dev)
          op: assign_op.Equal
          rhs: {(DQ )}
          spids: [39]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'makedepends='> name:makedepends)
          op: assign_op.Equal
          rhs: {(DQ ($ Id.VSub_DollarName depends_dev) <' attr-dev lua5.1-dev ncurses-dev perl'>)}
          spids: [43]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'install='> name:install)
          op: assign_op.Equal
          rhs: {(DQ )}
          spids: [49]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'subpackages='> name:subpackages)
          op: assign_op.Equal
          rhs: {(DQ ($ Id.VSub_DollarName pkgname) <-doc>)}
          spids: [53]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'source='> name:source)
          op: assign_op.Equal
          rhs: 
            {
              (DQ <'https://github.com/chaos/diod/releases/download/'> ($ Id.VSub_DollarName pkgver) 
                <'/diod-'> ($ Id.VSub_DollarName pkgver) <'.tar.gz\n'> <'\tdiod.initd'>
              )
            }
          spids: [59]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike '_builddir='> name:_builddir)
          op: assign_op.Equal
          rhs: {(DQ ($ Id.VSub_DollarName srcdir)) <'/diod-'> ($ Id.VSub_DollarName pkgver)}
          spids: [70]
        )
      ]
      redirects: []
    )
    (command.ShFunction
      name: prepare
      body: 
        (BraceGroup
          left: <Id.Lit_LBrace '{'>
          children: [
            (C {<local>} {<i>})
            (C {<cd>} {(DQ ($ Id.VSub_DollarName _builddir))})
            (command.ForEach
              iter_names: [i]
              iterable: (for_iter.Words words:[{($ Id.VSub_DollarName source)}])
              body: 
                (command.DoGroup
                  children: [
                    (command.Case
                      to_match: {($ Id.VSub_DollarName i)}
                      arms: [
                        (case_arm
                          pat_list: [{<Id.Lit_Star '*'> <.patch>}]
                          action: [
                            (command.Sentence
                              child: (C {<msg>} {($ Id.VSub_DollarName i)})
                              terminator: <Id.Op_Semi _>
                            )
                            (command.AndOr
                              ops: [Id.Op_DPipe]
                              children: [
                                (C {<patch>} {<-p1>} {<-i>} 
                                  {(DQ ($ Id.VSub_DollarName srcdir)) <'/'> ($ Id.VSub_DollarName i)}
                                )
                                (command.ControlFlow
                                  token: <Id.ControlFlow_Return return>
                                  arg_word: {<1>}
                                )
                              ]
                            )
                          ]
                          spids: [115 117 141 -1]
                        )
                      ]
                      redirects: []
                    )
                  ]
                )
              redirects: []
            )
          ]
          redirects: []
          right: <Id.Lit_RBrace '}'>
        )
    )
    (command.ShFunction
      name: build
      body: 
        (BraceGroup
          left: <Id.Lit_LBrace '{'>
          children: [
            (C {<cd>} {(DQ ($ Id.VSub_DollarName _builddir))})
            (command.AndOr
              ops: [Id.Op_DPipe]
              children: [
                (C {<'./configure'>} {<--prefix> <Id.Lit_Equals '='> <'/usr/'>} 
                  {<--sysconfdir> <Id.Lit_Equals '='> <'/etc/diod'>} {<--sbindir> <Id.Lit_Equals '='> <'/usr/bin'>}
                )
                (command.ControlFlow
                  token: <Id.ControlFlow_Return return>
                  arg_word: {<1>}
                )
              ]
            )
            (command.AndOr
              ops: [Id.Op_DPipe]
              children: [
                (C {<make>})
                (command.ControlFlow
                  token: <Id.ControlFlow_Return return>
                  arg_word: {<1>}
                )
              ]
            )
          ]
          redirects: []
          right: <Id.Lit_RBrace '}'>
        )
    )
    (command.ShFunction
      name: package
      body: 
        (BraceGroup
          left: <Id.Lit_LBrace '{'>
          children: [
            (C {<cd>} {(DQ ($ Id.VSub_DollarName _builddir))})
            (command.AndOr
              ops: [Id.Op_DPipe]
              children: [
                (C {<make>} {<Id.Lit_VarLike 'DESTDIR='> (DQ ($ Id.VSub_DollarName pkgdir))} {<install>})
                (command.ControlFlow
                  token: <Id.ControlFlow_Return return>
                  arg_word: {<1>}
                )
              ]
            )
            (C {<ln>} {<-s>} {<diodmount>} {(DQ ($ Id.VSub_DollarName pkgdir)) <'/usr/bin/mount.diod'>})
            (C {<rm>} {<-rf>} {(DQ ($ Id.VSub_DollarName pkgdir) <'/etc/dios/systemd'>)})
            (command.AndOr
              ops: [Id.Op_DPipe]
              children: [
                (C {<install>} {<-Dm755>} {(DQ ($ Id.VSub_DollarName srcdir)) <'/diod.initd'>} 
                  {(DQ ($ Id.VSub_DollarName pkgdir)) <'/etc/init.d/diod'>}
                )
                (command.ControlFlow
                  token: <Id.ControlFlow_Return return>
                  arg_word: {<1>}
                )
              ]
            )
          ]
          redirects: []
          right: <Id.Lit_RBrace '}'>
        )
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'md5sums='> name:md5sums)
          op: assign_op.Equal
          rhs: 
            {
              (DQ <'00566e5d43452b977ddc607181ab2288  diod-1.0.24.tar.gz\n'> 
                <'18f81219f1a64ac596ff94e595689d43  diod.initd'>
              )
            }
          spids: [286]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'sha256sums='> name:sha256sums)
          op: assign_op.Equal
          rhs: 
            {
              (DQ 
                <
'f41d2b91c1a712132f5457d9d1c3caca985f069bdc8ef27bf4c148ac1d9f8c9f  diod-1.0.24.tar.gz\n'
                > <'48d8db2ffc992a2bc8f4d5446e804004932a0050cfd9d6e7b85824474e43b9b6  diod.initd'>
              )
            }
          spids: [292]
        )
      ]
      redirects: []
    )
    (command.ShAssignment
      pairs: [
        (assign_pair
          lhs: (sh_lhs_expr.Name left:<Id.Lit_VarLike 'sha512sums='> name:sha512sums)
          op: assign_op.Equal
          rhs: 
            {
              (DQ 
                <
'844adc84a2dd705dd94b1103de2a466ae94314d884d8889b6d850a08074d21ac7f5cd40e17ea63ae63cd171adfba3e1601f992d5789709699d74cc8dc8c2c663  diod-1.0.24.tar.gz\n'
                > 
                <
'963721cb06a5761101387b869f7513ffcfd2cd0e1b1bb57fb3c987d18827bc4bac6e66556b9ae6c67d3581c04565052aed410513fb2294d1e1fa235bbd7aaf9c  diod.initd'
                >
              )
            }
          spids: [298]
        )
      ]
      redirects: []
    )
  ]
)